e-shop Sapro BENDR SK

AB-FÓRUM - Satelitné fórum (Satelity, DVB-T, DVB-C)

Česko-Slovenské diskusní fórum nejen o satelitním příjmu televizních programů.
Právě je 21.Srpen 2018 - 8:50

Všechny časy jsou v UTC+02:00




Poslat nové téma  Odpovědět do tématu  [ 7 příspěvků ] 
Autor Zpráva
PříspěvekOdeslal: 22.Prosinec 2016 - 11:32 
Offline
Registrovaný
Registrovaný

Registrován: 25.Leden 2016 - 2:29
Příspěvky: 8
Zdravím, mám problém s overením streamu TV pri používaní VLC Playera. Mám Golden Interstar Xpeed LX3 a v ňom posledný OpenATV 5.3 . Pred včerom som aktualizoval s OpenATV 5.1 original elano kedže som mal podozrenie že problém robí staršia verzia OpenATV. Jedná sa o HTTP stream kedže mám 4 tunery občastne by sa mi zišla možnosť pozrieť si TV na PC. Kedže mám stream zabezpečený vyžaduje sa heslo. Teda mám zapnutú funkciu "Vyžadovať prihlásenie pre http stream" . Problém je však taký že na niektorých PC to funguje a na niektorých nie. Napríklad na mojom PC zadám adresu url streamu do VLC vo formáte http://mojaip/:8001/1:0:19:3398:C89:3:EB0000:0:0:0: vyskočí tabuľka s požiadavkov na zadanie prihlasovacieho mena a hesla. To však vyplním správne no stream sa nespustí a znova dookola pýta meno a heslo.
Obrázek
Pokiaľ urobím to isté na notebooku používam rovnakú verziu VLC Playera tam sa stream bez problémov spustí, mám doma ďalšie 2 notebooky ktoré som opravoval skúšal som nainštalovať čerstvo na obidva VLC Player na 1 notebooku stream funguje bez problémov na druhom nie, skúšal som sa prihlasovať aj z práce a stream rovnako funguje. Pokiaľ zadám URL adresu streamu do prehliadača na notebookoch "http://mojaip/:8001/1:0:19:3398:C89:3:EB0000:0:0:0:" vyskočí mi tabuľka prep prihlásenie po zadaní sa začne sťahovať súbor "1-0-19-3398-C89-3-EB0000-0-0-0-.mpeg" Tento súbor si otvorím vo VLC ktorý sa práve sťahuje a môžem stream sledovať. Prihlasenie mi nefunguje ani na telefóne z Androidom no sledovať stream je možné po zadaní URL do prehliadača a začaní sťahovania streamu rovnako ako na PC. Kvôli tomu som preinštaloval originál OpenATV od Ellano myslel som že bude chyba tam, funguje mi všetko ako má no začínam mať podozrenie teda som si skoro istý že problém nebude v Image ale niekde inde. Jednoducho povedané niekde to ide niekde nie. Konkrétne som skúšal 5 notebookov 1 PC a môj telefón. Na mojom notebooku streamy fungujú Na notebooku sestry stream funguje tak isto 2 notebooky ktoré som mal na opravu na jednom funguje bez problémov na druhom to nefunguje vôbec dookola pýta prihlasenie aj keď je zadané správne na firemnom notebooku funguje tak isto a na mojom PC a telefóne stream nefunguje. Vedel by mi niekto poradiť kde by mohol byť problém ? Som v linuxových sat. prijímačoch nováčik iba pred nedávnom som ho preinštaloval nastavoval celý no linux mi nieje až tak neznámy a všetko som zvládol a nastavil podľa návodov sám. Pluginy nemám veľa iba nejaké softcam a CSFD plugin. Najprv som si myslel že problém s prihlasovaním robí plugin archívy czsk resp. ním doinštalované pluginy GStreamer a podobne ale nebude to ani tým. Ďakujem za každý podnet a odpoveď ak by ste chceli nejaké bližšie info poskytnem.


Nahoru
   
PříspěvekOdeslal: 22.Prosinec 2016 - 18:05 
Offline
Veterán fóra
Veterán fóra

Registrován: 03.Březen 2012 - 20:44
Příspěvky: 1141
Poděkoval: 17 krát
Poděkováno: 43 krát
pokial to funguje aspon na 1 PC, tak by som chybu nehladal v prijimaci. No ak si si isty, ze je to prijimacom (co podla mna nie je) skusil by som tam dat cisty image ATV 5.3 (pretoze online update zvykne kadeco pokazit). Taktiez s image-mi od ellano nemam dobre skusenosti (je tam toho strasne vela a nevyladene).

Cize sprav zalohu terajsieho image a skus tam dat ciste ATV 5.3 (alebo hladaj chybu v PC, kde to nefunguje)

_________________
Golden Interstar Xpeed LX3 [E2 - ATV], lcd4linux - SAMSUNG SPF-107H
auto update picons, ASUS router OSCam, enigma2 OSCam


Nahoru
   
PříspěvekOdeslal: 23.Prosinec 2016 - 18:36 
Offline
Registrovaný
Registrovaný

Registrován: 25.Leden 2016 - 2:29
Příspěvky: 8
Nahadzoval som nový image som si takmer istý že to nieje prijímačom, prví krát som myslel že chyba bude tam a so starým openATV ale teraz som dal čistý openATV 5.3 nahral si len nejaké softcam nemám ani dalšie blbosti pluginy od ellana. Robí to aj tak a ide to na viacerích PC len proste niektoré z nejakého dôvodu nejdu, rozmýšľal som že by to mohol byť ešte firewall ale to je hlúposť .


Nahoru
   
PříspěvekOdeslal: 23.Prosinec 2016 - 18:43 
Offline
Odborník
Odborník

Registrován: 16.Březen 2012 - 15:32
Příspěvky: 321
Poděkoval: 38 krát
Poděkováno: 13 krát
pouzi url
_http://meno:heslo@mojaip/:8001/1:0:19:3398:C89:3:EB0000:0:0:0:

_________________
ET10000, DM900 Triple, OpenPLI, OpenATV...


Nahoru
   
PříspěvekOdeslal: 24.Prosinec 2016 - 12:21 
Offline
Registrovaný
Registrovaný

Registrován: 25.Leden 2016 - 2:29
Příspěvky: 8
Urobí to presne to isté stream sa ide spustiť ale vyhodí znova tabuľku pre prihlásenie a aj tak to nefunguje. Rovnaký problém a nefunguje to iba na PC na ktorých to nešlo napr na mojom aj sestrynom notebooku stream ide spustiť aj tak. zadaním mena hesla priamo do url linku streamu.


Nahoru
   
PříspěvekOdeslal: 24.Prosinec 2016 - 18:32 
Offline
Odborník
Odborník

Registrován: 16.Březen 2012 - 15:32
Příspěvky: 321
Poděkoval: 38 krát
Poděkováno: 13 krát
hmm, vyzera ze je to zalezitost klienta(vlc),
- ako prve by som odskusal vypnut zabezpecenie na streame - ci to ide na problematickych strojoch

- nastavenie "pouzit zabezpecenie streamu" sa da nastavit na viacerych miestach (nastavenie pluginu OpenWebIf, Menu/nastavenie/prisposobenie/...) vyskusat kombinacie

- cez telnet a prikaz "useradd" vytvorit ineho uzivatela ako root, nastavit mu heslo, a vo vlastnostiach pluginu zakazat prihlasenie uzivatelovi root, mozno bude potrebne hodit noveho uzivatela do administratorskej grupy

- celkom podnetny je link _https://forums.openpli.org/topic/37715-authentication-for-streaming-and-change-port/?hl=openwebif#entry488045
najme cast kde sa stream stahuje cez wget, tam moze byt vidno na com to zlyhava

_________________
ET10000, DM900 Triple, OpenPLI, OpenATV...


Nahoru
   
PříspěvekOdeslal: 02.Září 2017 - 17:33 
Offline
Registrovaný
Registrovaný

Registrován: 25.Leden 2016 - 2:29
Příspěvky: 8
Skúšal som rôzne kombinácie a možnosti a vôbec sa mi to nepodarilo spraviť. Keď vypnem prihlasovanie pre http stream funguje bez problémov avšak skúsil som zmeniť port openwebif na pôvodný 80 pretože som mal nastavený port 88. Už som myslel že funguje bez problémov a prihlasilo ma na stream avšak hneď to prestalo fungovať. Prišiel som na zaujímavu vec, keď pustím stream a zadám údaje vôbec to nezoberie a nepusti stream. Ale keď do prehliadača dám IP adresu boxu a vyhodí mi prihlasenie do openwebif vyplním údaje prihlasim sa a keď do pár sekúnd pustím stream a zadám prihlasovacie udaje stream sa pustí a funguje normálne. Ale keď stream vypnem a znova spustím znova prihlasenie nefunguje a nieje možné pustiť stream. Vôbec tomu nerozumiem a neviem kde hľadať chybu.


Nahoru
   
Zobrazit příspěvky za poslední:  Seřadit podle  
Poslat nové téma  Odpovědět do tématu  [ 7 příspěvků ] 

Všechny časy jsou v UTC+02:00


Kdo je online

Uživatelé prohlížející si toto fórum: Nejsou tu žádní registrovaní uživatelé a 1 host


Nemůžete posílat nová témata
Nemůžete odpovídat v tématech
Nemůžete upravovat vlastní příspěvky
Nemůžete mazat vlastní příspěvky
Nemůžete posílat přílohy

Najít:
Přejít na:  
ellano.sk